Open data model

i’m running studio from inside of 4d.
i created a new app
now i’m trying to create the data model
double-clicking on “model” does not seem to do anything. i am using ff 117.0
i have tried with both a regular tab and a private tab

  • i tried stopping/starting the webserver
  • quitting/reloading 4d
  • reloading the web page
  • creating a table in the project
  • creating a class in qodly studio (it shows up inside of 4d)
  • launching the data explorer from qodly studio (table shows up)

Please ask questions about Qodly Studio used with 4D (or with 4D concepts) in the 4D forum…

i am so utterly confused, now.
if the web-based interface doesn’t work, as expected, how you get there determines which forum you should ask in?
what if some other feature, such as a script doesn’t work?
i think we need some pretty clear guidance on this topic, because this seems like a no-brainer that this issue should be raised over here.

Hey mikey

if you are working on then this is the right place. but if you use qodly studio on your local machine using 4D then you should add your question un the 4D Forum

PS: avoid creating tables using 4D and then using them in qodly stud;io that may cause you some issues. plz use the data model to create the tables . i will DM for more details

Hi mikey,

Check the 4D doc. The model editor is only available with apps.


ah, i missed that in the 4d docs.