Publishing a Qodly app created in 4D

Next to dabbling with the standalone version of Qodly I also created a little web app with Qodly Studio from within my 4D development app.

I have learned from Thomas Maul that, given the proper license keys, both with 4D v20 R2 and v20R3 a Qodly app can be published with a 4D engined runtime or engined server.

I tried just that, with the proper BuildApp setting PackProject=false, but calling the web app with IP:port/$lib/renderer/?w=WebFormName results in a 404. WebAdmin Server is active, REST license is there.

Any ideas what I am doing wrong? I tried both localhost and the actual IP of my machine, also with port 7080 and 7443, but I don’t get it to work. It seems as if the webform I’m specifying is not found, but checking on my application package it is definitely there.

Hi Tilman,

For question about Qodly Studio for 4D, best is to write on But no big deal I’ll answer here.
You may have this problem because you engine your app in a packed 4DZ. This is currently not supported but we’re working on it.
Try not to pack and it should work.


Thank you for helping anyway. I did set PackProject to false.
I’ve received a tip from Thomas to use port 80 or 443 but whatever I do, the best I get is a 404 from 4D.

I have also just recently renewed my v20 OEM licenses, I have the REST test license for 3 users. REST server is active.

I also defined an access key, but that also made no difference.

The webform is inside the Sources folder structure in my compiled application, server and engined runtime. Do I have to manually copy that to someplace else?

I must admit, the whole setup for the 4D based Qodly installation is much more cumbersome than the web only product. Setting options manually that need to be set anyway is not ideal.

I’d really love to get this up and running but on the other hand I’m wasting time trying all kinds of options without knowing what will actually make a difference.